Updating Project and SharePoint 2010 Demo VM with the latest Cumulative Update

Following the recent release of the December 2010 Cumulative Updates for Project, Project Server and SharePoint 2010 , I have decided to update my demo VM. Please find below a quick step by step procedure to install this CU and others yourself and ensure you are using the latest and greatest version of our favorite products (as usual plenty more content, recommendations, recorded webcast on TechNet on applying software updates: http://technet.microsoft.com/en-US/projectserver/gg176680.aspx ). Create a snapshot in Hyper-V before applying any updates Download the hotfix package: Project Server http://support.microsoft.com/kb/2459258 & Project Professional: http://support.microsoft.com/kb/2466263 Execute the server package ( office2010-kb2459258-fullfile-x64-glb ), will take a few minutes, then run the SharePoint Configuration wizard. After you run the wizard once you might get errors in the upgrade logs saying something like this (lets ignore these for now): OWSTIMER SPContentDatabaseSequence INFO 1/25/2011 3:29:28 PM: SPContentDatabase Name=PWA_WSS_content_80 OWSTIMER SPContentDatabaseSequence ERROR 1/25/2011 3:29:28 PM: Found a missing feature Id = 367b94a9-4a15-42ba-b4a2-32420363e018, Name = Report Server Integration Feature, Description = Enables rich reporting using Microsoft SQL Server Reporting Services., Install Location = ReportServer OWSTIMER SPContentDatabaseSequence INFO 1/25/2011 3:29:28 PM: SPContentDatabase Name=PWA_WSS_content_80 OWSTIMER SPContentDatabaseSequence ERROR 1/25/2011 3:29:28 PM: The feature with Id 367b94a9-4a15-42ba-b4a2-32420363e018 is referenced in the database PWA_WSS_content_80, but is not installed on the current farm. The missing feature may cause upgrade to fail. Please install any solution which contains the feature and restart upgrade if necessary. OWSTIMER SPContentDatabaseSequence INFO 1/25/2011 3:29:28 PM: SPContentDatabase Name=PWA_WSS_content_80 OWSTIMER SPContentDatabaseSequence WARNING 1/25/2011 3:29:28 PM: WebPart class 8d6034c4-a416-e535-281a-6b714894e1aa is referenced 15 times in the database PWA_WSS_content_80, but is not installed on the current farm. Please install any feature/solution which contains this web part. (…) Re-run the Wizard, and it should be successful the second time;


Leave a comment!

You must be logged in to post a comment.